CHF Withdrawal Outage
Incident Report for SwissBorg
Resolved
CHF withdrawals are now being processed normally.
Posted Nov 20, 2024 - 15:31 UTC
Identified
Withdrawals for CHF are currently not working properly due to an issue with our banking partner.
We are investigating with them to fix this situation as soon as possible.
Posted Nov 20, 2024 - 11:15 UTC
This incident affected: FIAT payments.