Possible delays with identity verification

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 07:57 UTC

Identified

We are currently facing some delays with onboarding and verifications.
Posted Jul 10, 2025 - 07:39 UTC
This incident affected: Onboarding.