Infrastructure partner outage affecting Web App and wallet verification procedure

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 12:29 UTC

Investigating

We are experiencing a temporary outage with an infrastructure provider used by the SwissBorg Web App and for wallet verifications.

Web App:
The Web App is currently unavailable. Our mobile app remains fully operational.

Wallet Verifications:
Your deposits and withdrawals are not restricted in any way. However, when attempting to verify a wallet address users may see an error message - "Internal Server Error"

In this case, you may simply restart the withdrawal procedure and instead of tapping the verify wallet button, select unverified address from the list, and you will be able to withdraw as normal.

Similarly, for accepting a deposit from your self-hosted wallet, you may use the “manual verification” option.

Our support team remains at your disposal for any questions. We apologise for any inconvenience caused.
Posted Jul 16, 2026 - 11:39 UTC
This incident affected: SwissBorg website.