WXM Purchase Temporarily Disabled

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 09:00 UTC

Identified

The purchase of WXM has been temporarily disabled due to depleted liquidity on the decentralized exchanges (DEXs) where we execute trades.

Our team is working closely with the WXM team to restore trading, with the goal of enabling purchases again by next week.

Thank you for your understanding!
Posted May 29, 2025 - 08:40 UTC
This incident affected: Cryptocurrency payments and Exchanges.