Exchanges execution issue

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 08:27 UTC

Investigating

We are currently facing intermittent issues with exchange execution. The team is investigating it.
Posted Jul 17, 2025 - 08:20 UTC
This incident affected: Exchanges.