Cardano Blockchain (ADA) is experiencing partial outage

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 08:13 UTC

Identified

The Cardano Blockchain (ADA) Mainnet is currently experiencing a partial outage. You can track the Cardano Explorer status page here: https://cardanoscan.io/ to check the last block mined. The chain is processing slowly.

Please note that the issue is related to the Cardano blockchain itself and not our provider's infrastructure.
Our blockchain provider has blocked the Cardano Blockchain until the issue subsides.
Posted Nov 21, 2025 - 11:20 UTC
This incident affected: Cryptocurrency payments and Exchanges.