Issues with trading
Incident Report for SwissBorg
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 14:50 UTC
Investigating
We are currently experiencing technical difficulties related to exchanges. Some operations (Buy/Sell) might be affected.
Posted Jan 01, 2024 - 11:18 UTC
This incident affected: Exchanges.