MYX Trading Issue

Incident Report for SwissBorg

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2025 - 11:17 UTC

Update

The issue has been identified: our trading capability on the BNB Smart Chain is impacted. Other tokens tradable or BNB Smart Chain are impacted at this moment as well.
Posted Aug 05, 2025 - 11:28 UTC

Identified

We are experiencing difficulties processing MYX trades, MYX trading is suspended.
We are currently investigating this issue.
Posted Aug 05, 2025 - 10:28 UTC
This incident affects: Exchanges.