Trading of CAPS is suspended
Incident Report for SwissBorg
Resolved
Trading of CAPS is still suspended.
Posted Sep 09, 2024 - 15:26 UTC
Identified
We would like to inform our users that trading of CAPS is suspended, while withdrawals are still possible.
We will update as we gain more information.
Posted Jul 02, 2024 - 07:44 UTC
This incident affected: Cryptocurrency payments and Exchanges.