Support Update: High Volumes - Anticipate Delay in Ticket Processing

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jan 12, 2024 - 09:07 UTC

Identified

Our support team is currently experiencing an exceptionally high volume of tickets, and we want to inform you that processing times may be longer than usual.

Our team is working diligently to address each inquiry and provide the quality assistance.

We appreciate your patience during this busy period.
Posted Nov 14, 2023 - 14:33 UTC
This incident affected: SwissBorg application.