Fiat Payment partner maintenance

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 09:12 UTC

Investigating

One of our payment partners is currently undergoing some emergency maintenance. All SEPA Instant payments are currently delayed. They will be scheduled for processing at the next available opportunity.
Posted Oct 06, 2025 - 10:45 UTC
This incident affected: FIAT payments.