App downtime

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Dec 07, 2023 - 14:13 UTC

Update

The SwissBorg app is down due to unexpected maintenance. We ask for your patience as we work to restore services quickly! Your Funds Are Safe.
Posted Dec 07, 2023 - 13:01 UTC

Investigating

We are currently investigating this issue.
Posted Dec 07, 2023 - 12:39 UTC
This incident affected: SwissBorg application.