CHF Transactions Delay
Incident Report for SwissBorg
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 13:36 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 13:36 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 11:36 UTC
Update
Deposits and withdrawals for CHF are currently not working properly due to an issue with our banking partner, related to the general IT outage occurring worldwide.
Our partner is working to fix this situation as soon as possible.
Deposits in other currencies are working properly.
Posted Jul 19, 2024 - 11:35 UTC
Identified
Deposits for CHF are currently not arriving due to an issue related to our banking partner.
Our partner is working to fix this situation as soon as possible.
Deposits in other currencies are working properly.
Posted Jul 19, 2024 - 07:30 UTC
This incident affected: FIAT payments.