Temporary Payment Delay

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 11:39 UTC

Investigating

We are currently experiencing a technical interruption affecting several currency transfers via our partner. This is due to urgent maintenance at a third-party provider.

Affected Currencies (SWIFT only):

CHF, CZK, DKK, HUF, NOK, PLN, RON, SEK

Current Status:

Outgoing and incoming payments for these currencies are temporarily restricted.

The provider is working to restore the connection with high priority.

We will provide an update as soon as systems are back online. We apologize for the inconvenience.
Posted Mar 11, 2026 - 13:09 UTC
This incident affected: FIAT payments.