GBP and EUR deposits and withdrawals may be delayed temporarily

Incident Report for SwissBorg

Resolved

The issue has been resolved and payments are being processed normally. If you should notice any issues, please do not hesitate to contact our support team - https://help.swissborg.com/hc/en-gb/articles/14883477512593-Contact-Support
Posted Jul 24, 2026 - 06:21 UTC

Update

The issue has been partially resolved, and the majority of the delayed payments have been successfully processed. Our teams continue to work closely with the relevant parties to fully restore normal service.

You may still experience occasional delays with some payments until the issue is completely resolved.
Posted Jul 23, 2026 - 09:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 09:41 UTC

Investigating

One of our partner service providers is currently experiencing a technical issue that may result in deposits and withdrawals of GBP and EUR being delayed.

Affected transfers will be processed once service is restored. There is no need to resubmit your payment.

We apologise for any inconvenience caused.
Posted Jul 23, 2026 - 07:55 UTC
This incident affected: FIAT payments.