Issue with Avalanche (AVAX) Trading

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 08:32 UTC

Investigating

We're currently experiencing issues with trading Avalanche (AVAX) tokens. Our team is investigating and working to resolve the problem as soon as possible.
Thank you for your patience.
Posted Jun 06, 2025 - 08:52 UTC
This incident affected: Cryptocurrency payments.