Crypto Withdrawals Issue

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 07:24 UTC

Identified

Our blockchain provider is currently experiencing an issue that is causing a delay.
We are actively investigating this issue.
Posted Jan 29, 2026 - 07:09 UTC
This incident affected: Cryptocurrency payments.