SwissBorg App Inaccessible

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 14:01 UTC

Identified

The SwissBorg app is facing technical issues and is inaccessible. Our team is working hard to fix this issue.
Posted Feb 24, 2026 - 13:54 UTC
This incident affected: SwissBorg application.