Fiat Deposits and Withdrawals (UK & Spain - GBP and EUR)

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 10:48 UTC

Identified

We are currently experiencing disruptions with fiat deposits and withdrawals affecting our community in the UK and Spain.

This issue originates from our external partner's system. We are actively working with their technical team to restore full service as quickly as possible.

Impact: Fiat deposits and withdrawals of EUR and GBP for our community in the UK and Spain.

All user funds remain completely safe. No other app features or regions are affected.

We apologise for any inconvenience caused and will provide further updates here as soon as they are available.
Posted Jun 23, 2026 - 06:33 UTC
This incident affected: FIAT payments.