MANTRA Chain deposits and withdrawals are temporarily unavailable

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 08:01 UTC

Identified

MANTRA Chain deposits and withdrawals are temporarily unavailable after the MANTRA team halted the network as a precaution while it investigates an incident.

Further information is available on the project’s status page: https://status.mantrachain.io/
Posted Aug 21, 2026 - 10:18 UTC
This incident affected: Cryptocurrency payments.