Trading issue with Golden Thematic

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 13:05 UTC

Identified

We have identified an issue faced when trading with the Golden Thematic product. We are working to resolve this issue as soon as possible.
Posted Mar 25, 2025 - 08:10 UTC
This incident affected: Exchanges.