Delays or errors during onboarding and verification

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 19:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 08, 2026 - 17:52 UTC

Identified

Users may experience delays or errors during onboarding and verification at present. Our team is actively working on a fix and we appreciate your patience.
Posted Jun 08, 2026 - 17:50 UTC
This incident affected: SwissBorg application.