Kraken Connector Incident

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 08:09 UTC

Identified

We’re currently experiencing an issue with our Kraken integration, affecting trading for a number of tokens. We've identified the root cause and are actively working on a fix, together with Kraken.

Trading for these tokens remains temporarily unavailable. We’ll keep you updated as we make progress.

Thank you for your patience. 🙏
Posted Jun 26, 2025 - 07:24 UTC
This incident affected: Cryptocurrency payments and Exchanges.