ATOM transfers delayed due to Cosmos Hub downtime

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 14:04 UTC

Monitoring

Cosmos Hub validators have temporarily halted the network.

As a result, ATOM-Cosmos deposits and withdrawals will be delayed until the network restarts and transaction traffic clears.

We recommend waiting before making any ATOM transfers until the situation is resolved.

We are monitoring the situation and will provide an update once normal service resumes. Your funds remain safe and tradeable as usual.

We apologise for any inconvenience caused.
Posted Sep 22, 2026 - 13:37 UTC
This incident affected: Cryptocurrency payments.