We are currently investigating an issue affecting trading of the $PURR token.

Incident Report for SwissBorg

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 12:46 UTC

Investigating

We are currently investigating an issue affecting trading of the $PURR token.

Other assets aren't affected. Your PURR tokens remain in your account.

We will update here as soon as we have further information and apologise for any inconvenience caused.
Posted Jul 30, 2026 - 09:58 UTC
This incident affected: Exchanges.